active mode connections

Please post here if you have problems in using Wing FTP Server.

active mode connections

Postby stormsurge » Fri Apr 16, 2010 3:07 pm

does Wing FTP work in active mode or just passive, or both? Using pasv mode with a client I have no trouble, but I'm having problems connecting to it using active mode (ie. from a command line, script or client with pasv turned off). It will make the connection but stall when trying to list the directories etc. Our apache FTP server doesn't have this problem and the firewall configuration is the same for both FTP servers.

Andrew
stormsurge
 
posts 3
 
joined Fri Apr 16, 2010 2:50 pm

Re: active mode connections

Postby FTP » Fri Apr 16, 2010 3:18 pm

I guess its your client side issue, if you don't believe, please try to connect our demo server.

Location: demo.wftpserver.com
Username: demo-user
Password: demo-user
FTP
Site Admin
 
posts 1200
 
joined Tue Sep 29, 2009 6:09 am

Re: active mode connections

Postby stormsurge » Fri Apr 16, 2010 4:09 pm

when I connect via dos command line to your demo server it works fine. Still no luck connecting to our test Wing FTP server however. Could this be a limitation of running Wing in demo mode (unregistered)?
stormsurge
 
posts 3
 
joined Fri Apr 16, 2010 2:50 pm

Re: active mode connections

Postby FTP » Fri Apr 16, 2010 4:50 pm

Hi Stormsurge,

Active mode means the server will proactively connect the client when doing list or transferring files, while the pasv mode means the client initiates the connect to the server.

By default, WingFTP will use port 20 to connect the client. However, when port 20 is used by other app, WingFTP will have to try another port. Port 20 is generally regarded as safe and trustful by most firewalls. So when the server uses a port other than port 20, the firewall maybe label it as untrustful and refuse the connection. In order to make the setting work, you should be sure that port 20 is not occupied by other app.

Hope this can help you solve the problem, if not, you can email us and tell us your server address, the FTP username and password, we will test it for you.
FTP
Site Admin
 
posts 1200
 
joined Tue Sep 29, 2009 6:09 am

Re: active mode connections

Postby stormsurge » Fri Apr 16, 2010 5:24 pm

I've manged to get it working. Here is the situation:
Wing FTP is installed on CentOS, which had 2 IP's bound to a single network card.
eth0 = xx.xx.xx.63
eth0:0 = xx.xx.xx.64
WingFTP was then told to use .64 for it's listeners (ftp and http). CentOS httpd was bound to xx.63 for some regular web server work.
This when I had the issues with active mode connections.
When I switched the IP bindings so eth0 was now xx.64 and eth0:0 was xx.63 everything works. So it seems like Wing FTP just needed to be tied to the first eth0 configuration for some reason.
stormsurge
 
posts 3
 
joined Fri Apr 16, 2010 2:50 pm

Re: active mode connections

Postby FTP » Fri Apr 16, 2010 5:32 pm

I'm glad to hear about your success, and I guess your issue may be related with firewall settings.
FTP
Site Admin
 
posts 1200
 
joined Tue Sep 29, 2009 6:09 am


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest