SSL probs with pureftpd

Please post here if you have problems in using FTP Rush.

SSL probs with pureftpd

Postby b0nde » Tue Mar 30, 2010 1:24 pm


I am having trouble using encrypted data and listing to my web host ftp-server (pure-ftpd).

I am using Auth TLS (yes the server supports it)

If I enable encrypted listing, I am not able to browse the dir, it just hangs after MLSD / LIST (tried disabling MLSD)

If I disable encrypted listing, and enable encrypted data, I can login and browse fine, but when I try to upload, it hangs.

On the other hand, with FlashFXP v3.7.7 build 1315, there is no troubles, both listing and data encryption is working fine. That FlashFXP build uses WinSock 2.0 -- OpenSSL 0.9.8i 15 Sep 2008.
As you can see in the pastebin link, I use OpenSSL 0.9.8m 25 Feb 2010 with FTPRush. I have tried using OpenSSL 0.9.8m 25 Feb 2010 with FlashFXP too, and that does not break anything.

FTPRush log:
FlashFXP log:

So does FTPRush do "something" when it tries to ssl-transfer, that the installed version of pure-ftpd does not understand / support ? I have been in contact with my web host, and no one else is having trouble, which makes sense since I have no trouble when using FlashFXP.

Let me know if you need any more information.

Ps. FTPRush 1.1.3

Thank you!
posts 4
joined Tue Mar 30, 2010 1:09 pm

Return to Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest